lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3577) rename expungeDeletes
Date Tue, 15 Nov 2011 15:28:52 GMT


Yonik Seeley commented on LUCENE-3577:

bq. In practice expungeDeletes will usually be just like forceMerge(1) so for apps that must
have no deletes (eg maybe they need docFreq to be 100% accurate), they can call forceMerge(1)

If there are just a few deletes in a few small segments, using optimize instead of expungeDeletes
is much more expensive?
Although, it doesn't really seem like an important use case (ensuring there are no deletes).
> rename expungeDeletes
> ---------------------
>                 Key: LUCENE-3577
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
> Similar to optimize(), expungeDeletes() has a misleading name.
> We already had problems with this on the user list because TieredMergePolicy
> didn't 'expunge' all their deletes.
> Also I think expunge is the wrong word, because expunge makes it seem
> like you just wrangle up the deletes and kick them out of the party and
> that it should be fast.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message