lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Thu, 10 Nov 2011 09:22:51 GMT


Shai Erera commented on LUCENE-3564:

Ok, I think the API looks bad that way. If you don't want to do a poll on java-user, then
perhaps we should let people vote on dev@ on the principle of naming. I don't suggest to call
out a vote whenever we want to rename something. I feel that the way we're going will only
make the API ugly-er. It's a style thing, so you and I can debate on it forever :), but I
think that we both agree that it's important.
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>                 Key: LUCENE-3564
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message