lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-2191) rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
Date Tue, 01 Nov 2011 23:15:32 GMT


Uwe Schindler commented on LUCENE-2191:

Thanks. 3.x is more complicated, as we need very sophisticated VirtualMethod...
> rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
> -------------------------------------------------------------
>                 Key: LUCENE-2191
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Robert Muir
>            Priority: Minor
>             Fix For: 4.0
>         Attachments: LUCENE-2191.patch
> in TokenStream there is a reset() method, but the method in Tokenizer used to set a new
Reader is called reset(Reader).
> in my opinion this name overloading creates a lot of confusion, and we see things like
reset(Reader) calling reset() even in StandardTokenizer...
> So I think this would be some work to fulfill all the backwards compatibility, but worth
it because when you look at the existing reset(Reader) and reset() code in various tokenizers,
or the javadocs for Tokenizer, its pretty confusing and inconsistent.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message