lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doron Cohen (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Sun, 06 Nov 2011 17:18:51 GMT


Doron Cohen commented on LUCENE-3454:

bq. Perhaps I am the only one, but I find these ifNeeded, mabyeThis, mabyeThat method names
so ugly. I prefer JavaDoc for trying to catch the subtleties.

I feel that way too.

But a name change here seems in place, because as pointed above, there is an issue with current
catchy name *optimize()*.

My personal preference between the names suggested above is Mike's last one: *forceMerge(int)*:
- it describes what's done
- does not suggest to do wonders
- requires caller to think twice because of deciding to force a certain behavior
> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message