lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3577) rename expungeDeletes
Date Tue, 15 Nov 2011 13:51:51 GMT


Michael McCandless commented on LUCENE-3577:

+1.  The name does not indicate how horribly costly the operation is.

And it leads to apps deleting/updating a few docs and then calling .expungeDeletes.

We could also remove the method entirely?  TieredMP already "favors" merges that reclaim more
deletes (other things being equal), and you can change how strongly it does so (TMP.setReclaimDeletesWeight).

In practice expungeDeletes will usually be just like forceMerge(1) so for apps that must have
no deletes (eg maybe they need docFreq to be 100% accurate), they can call forceMerge(1) instead.
> rename expungeDeletes
> ---------------------
>                 Key: LUCENE-3577
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
> Similar to optimize(), expungeDeletes() has a misleading name.
> We already had problems with this on the user list because TieredMergePolicy
> didn't 'expunge' all their deletes.
> Also I think expunge is the wrong word, because expunge makes it seem
> like you just wrangle up the deletes and kick them out of the party and
> that it should be fast.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message