lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Tue, 08 Nov 2011 06:28:51 GMT


Shai Erera commented on LUCENE-3564:

The old IR.reopen has trapped users (two separate traps). I think the
change in semantics (return null if there is no change), and rename
and cutover to static method, are important steps forward (addressed
the traps).

I fully agree with the change in semantics of the API, but why did we have to add the 'IfNeeded'
part? What's wrong with just reopen() (as static)? BTW, when I call an .open() API, I expect
it to do it, and not 'IfNeeded', so I don't like it. We still have time to fix it before we
release 3.5.
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>                 Key: LUCENE-3564
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message