lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3577) rename expungeDeletes
Date Thu, 17 Nov 2011 00:55:52 GMT


Robert Muir commented on LUCENE-3577:

I'm constantly surprised by the number of people who are really picky about ensuring that
their tf/idf numbers are exact because they use them in a weird way

Do they know how we store normalization factors? :)
> rename expungeDeletes
> ---------------------
>                 Key: LUCENE-3577
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
> Similar to optimize(), expungeDeletes() has a misleading name.
> We already had problems with this on the user list because TieredMergePolicy
> didn't 'expunge' all their deletes.
> Also I think expunge is the wrong word, because expunge makes it seem
> like you just wrangle up the deletes and kick them out of the party and
> that it should be fast.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message