lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Fri, 04 Nov 2011 13:59:00 GMT


Yonik Seeley commented on LUCENE-3454:

bq. e.g.: why does an incremental DIH update trigger this by default?

Not sure...  If they actually meant for this to happen, this just reinforces my point that
the name of the call is not the issue.  The guys who wrote DIH absolutely know what optimize
does - hence if it was renamed they would have simply called maybeMerge(1) or whatever today.

At the time it was written, and depending on what it was used for, maybe it did make sense.

bq. You can keep lying to yourself that the only problem is complete morons, i'm not buying

That's exactly it - it's not morons, so a simple name change won't really help.  We need to
document the *current* tradeoffs so people can make more informed decisions about when to
optimize.  And some people will *still* chose to maybeMerge(1) when others think maybe they
shouldn't.  That's OK.

> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message