lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Thu, 10 Nov 2011 11:50:52 GMT


Michael McCandless commented on LUCENE-3454:

OK, LUCENE-3569 will explore the foreign MergePolicy approach.

Back to this issue... we won't be able to find a name that everyone
loves, of course (this is why naming is the hardest part!).

But forceMerge got at least some traction (3 people OK'd it), and it
does explain what you get from Lucene today, out of the box.  I think
it's a good improvement over what we have today (optimize).  Progress
not perfection...

Shai, are you absolutely dead set against the name "forceMerge"?  I
mean it's clear you'd like to do a bigger change (LUCENE-3569), but in
the mean time, forceMerge is at least better than optimize?

And if you are dead set against it, can you enumerate some alternative
names?  We need to find a name that nobody hates (hopefully
possible)... not one that everybody loves (not possible).

Naming is the hardest part ;)

> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message