lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Høydahl (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (SOLR-2204) Cross-version replication broken by new javabin format
Date Mon, 31 Oct 2011 16:31:32 GMT

    [ https://issues.apache.org/jira/browse/SOLR-2204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13140276#comment-13140276
] 

Jan Høydahl commented on SOLR-2204:
-----------------------------------

Perhaps change title to something more generic like "Better back compat support for requests"

My Avro comments relate also to SOLR-1535, and I think it could replace JavaBin2 (after a
deprecation period of course).

Thinking more about this back compat thing, there is of course a known workaround, namely
using XML. I just did that at a customer to be able to use v1.4.0 client towards v3.4 server.
Of course that is less efficient and would not work for replication, but then I don't really
see the usecase for cross version replication?

So I guess I still would like to see a more robust back compat support for requests in general,
but the JavaBin version problem is not really a blocker in most cases.
                
> Cross-version replication broken by new javabin format
> ------------------------------------------------------
>
>                 Key: SOLR-2204
>                 URL: https://issues.apache.org/jira/browse/SOLR-2204
>             Project: Solr
>          Issue Type: Bug
>          Components: replication (java)
>    Affects Versions: 3.1
>         Environment: Linux idxst0-a 2.6.18-194.3.1.el5.centos.plusxen #1 SMP Wed May
19 09:59:34 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
> java version "1.6.0_20"
> Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
> Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)
>            Reporter: Shawn Heisey
>             Fix For: 3.5, 4.0
>
>         Attachments: SOLR-2204.patch, SOLR-2204.patch
>
>
> Slave server is branch_3x, revision 1027974.  Master server is 1.4.1.  Replication fails
because of the new javabin format.
> SEVERE: Master at: http://HOST:8983/solr/live/replication is not available. Index fetch
failed. Exception: Invalid version or the data in not in 'javabin' format
> Switching Solr's internally generated requests to XML, or adding support for both javabin
versions would get rid of this problem.  I do not know how to do either of these things.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message