lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-2770) The Solr 3.4.0 release's maven artifacts don't include the jdk1.5-compiled carrot2-core jar
Date Wed, 19 Oct 2011 13:48:10 GMT

    [ https://issues.apache.org/jira/browse/SOLR-2770?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13130631#comment-13130631
] 

Steven Rowe commented on SOLR-2770:
-----------------------------------

Hi Richard,

I wasn't neither aware that maven-metadata.xml was hosed nor that it was the source of information
for range usage (though I must say that "[3.3.0]" as a range is really strange - why not just
use the exact version in that case?).

But you are not forced to upgrade.  You just specify the (exact) version you want in your
dependency declaration.  No?

FYI, issues like this would get more visibility on the solr-user mailing list.

Steve
                
> The Solr 3.4.0 release's maven artifacts don't include the jdk1.5-compiled carrot2-core
jar
> -------------------------------------------------------------------------------------------
>
>                 Key: SOLR-2770
>                 URL: https://issues.apache.org/jira/browse/SOLR-2770
>             Project: Solr
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 3.4
>            Reporter: Steven Rowe
>            Assignee: Steven Rowe
>            Priority: Minor
>         Attachments: SOLR-2770.patch
>
>
> The Solr-specific jdk1.5-compiled version of the carrot2-core jar (in {{solr/contrib/clustering/lib/}})
was not part of the 3.4.0 release - there should be a {{3.4.0/}} directory here but there
is not: http://repo1.maven.org/maven2/org/apache/solr/solr-carrot2-core/.  This artifact was
part of the 3.3.0 release.  The build system changes under SOLR-2452 are the cause.
> [Dawid Weiss indicated on SOLR-2428|https://issues.apache.org/jira/browse/SOLR-2428?focusedCommentId=13105381&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13105381]
that this Solr-specific jdk1.5-compiled artifact will continue to be required for the remainder
of the 3.X release line.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message