lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3466) Rename Analyzer.reusableTokenStream() to tokenStream()
Date Tue, 27 Sep 2011 12:33:11 GMT


Robert Muir commented on LUCENE-3466:

+1, though i have a few additional suggestions:
* TokenStream.reset() is described by the docs as optional, i think we should adjust the docs
* We might be able to re-word some of the stuff in Analyzer javadocs about inconsistencies
(Since these are gone!)

> Rename Analyzer.reusableTokenStream() to tokenStream()
> ------------------------------------------------------
>                 Key: LUCENE-3466
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Sub-task
>          Components: modules/analysis
>            Reporter: Chris Male
>            Assignee: Chris Male
>         Attachments: LUCENE-3466.patch
> All Analysis consumers now use reusableTokenStream().  To finally make reuse mandatory,
lets rename resuableTokenStream() to tokenStream() (removing the old tokenStream() method).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message