lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Willnauer (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3466) Rename Analyzer.reusableTokenStream() to tokenStream()
Date Tue, 27 Sep 2011 07:29:13 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3466?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13115283#comment-13115283
] 

Simon Willnauer commented on LUCENE-3466:
-----------------------------------------

awesome! This is the end of reusableTokenStream! If I remember correctly this work has started
in late 2009 and now it seems it only one commit away! Thanks chris!
                
> Rename Analyzer.reusableTokenStream() to tokenStream()
> ------------------------------------------------------
>
>                 Key: LUCENE-3466
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3466
>             Project: Lucene - Java
>          Issue Type: Sub-task
>          Components: modules/analysis
>            Reporter: Chris Male
>            Assignee: Chris Male
>         Attachments: LUCENE-3466.patch
>
>
> All Analysis consumers now use reusableTokenStream().  To finally make reuse mandatory,
lets rename resuableTokenStream() to tokenStream() (removing the old tokenStream() method).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message