lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan McKinley (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3464) Rename IndexReader.reopen to make it clear that reopen may not happen
Date Mon, 26 Sep 2011 23:23:12 GMT


Ryan McKinley commented on LUCENE-3464:

bq. the method implies that the reopen will happen "in place". And I've seen users try to
simply do IR.reopen().

funny, that's what i thought it did!

If you have to use the results value, should it be:
or something?

without the 'get' it seems like it operates on the reader itself, not the return value.

> Rename IndexReader.reopen to make it clear that reopen may not happen
> ---------------------------------------------------------------------
>                 Key: LUCENE-3464
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Bug
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
>         Attachments: LUCENE-3464.patch
> Spinoff from LUCENE-3454 where Shai noted this inconsistency.
> IR.reopen sounds like an unconditional operation, which has trapped users in the past
into always closing the old reader instead of only closing it if the returned reader is new.
> I think this hidden maybe-ness is trappy and we should rename it (maybeReopen?  reopenIfNeeded?).
> In addition, instead of returning "this" when the reopen didn't happen, I think we should
return null to enforce proper usage of the maybe-ness of this API.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message