lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan McKinley <ryan...@gmail.com>
Subject Re: solr - httpclient from 3.x to 4.1.x
Date Tue, 23 Aug 2011 13:07:04 GMT
I think upgrading to 4.x would be great -- for sure in /trunk, but
probably not in 3.x (since back compatibility would be complicated)

Migration has not happened because the 4.x migration is non-trivial
and back compatibility issues.

If you are willing to make the patch, i will review shepherd it along

thanks
ryan



On Tue, Aug 23, 2011 at 2:57 AM, Arvind Srini
<aravind.treasurata@gmail.com> wrote:
> Solr Server and hence, solrj, depends on commons-httpclient at the moment.
>  As we use the various solrj libraries in our app, we are using httpclient
> 4.1.x (eol has been announced for httpclient 3.x sometime ago).
> Going through archives, I see some interest expressed in the form of
> SOLR-861, say to move to httpclient 4.1.x codebase. I am trying to
> understand the sense of the community towards that long pending migration
> and am willing to work on the patch, but am interested in knowing some
> thoughts before I spend time on the same. Thanks !

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message