lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Male (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3376) Move ReusableAnalyzerBase into core
Date Tue, 16 Aug 2011 02:58:27 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13085506#comment-13085506
] 

Chris Male commented on LUCENE-3376:
------------------------------------

My plan was to move the class ReusableAnalyzerBase into core and then port all Analyzers over
to using it.  Then I would drop tokenStream() and rename ReusableAnalyzerBase to just Analyzer.

Manageable?

> Move ReusableAnalyzerBase into core
> -----------------------------------
>
>                 Key: LUCENE-3376
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3376
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Chris Male
>
> In LUCENE-2309 it was suggested that we should make Analyzer reusability compulsory.
 ReusableAnalyzerBase is a fantastic way to drive reusability so lets move it into core (so
that we can then change all impls over to using it).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message