lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Male <gento...@gmail.com>
Subject QueryParser names
Date Wed, 06 Jul 2011 05:00:48 GMT
Hi,

I'm in the process of consolidating the various QueryParsers into a single
queryparser module and Ryan reminded me that the names of the QPs could
probably be clearer.  For example, we currently have two parsers called
QueryParser.  Given that the core QueryParser is no longer going to be in
core, I think it could do with a name that more accurately describes its
purpose.

Does anybody have any thoughts on how to name the following parsers:

org.apache.lucene.queryParser.QueryParser (lucene core)
org.apache.lucene.queryParser.surround.parser.QueryParser (queryparser
contrib)
org.apache.lucene.queryParser.standard.StandardQueryParser (queryparser
contrib)

Cheers
Chris

-- 
Chris Male | Software Developer | JTeam BV.| www.jteam.nl

Mime
View raw message