lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dawid Weiss <dawid.we...@cs.put.poznan.pl>
Subject Re: commit-check target for ant?
Date Sat, 11 Jun 2011 06:04:11 GMT
> -0 ... wouldn't that mean that users running *actual* 1.5 JVM installs
> couldn't compile from source?  I think it would be a bad idea to say that
> our "compile" JVM requirements are differnet then our "run" JVM
> requirements.  I'd be more in favor of requireing 1.6 then having a weird
> build where 1.5 folks could use our binary releases but not compile
> themselves.

Ok, I get your point and I'm not going to force it, but I don't agree
people still running 1.5 should be able to compile from sources. I
mean: 1.5 has been dead for a longer while now; the same argument
could be made for java 1.4 or whatever most recent version has been
ported to amigaos... There are 1.6-compatible VMs from all major
vendors. Really -- if you're still using java 1.5 you're a fossil and
should consider switching to 1.6 (if not for anything else, then for
performance reasons).

This said, I'm fine with 1.5 source-level compatibility, doesn't
bother me that much.
Dawid

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message