lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DM Smith <dmsmith...@gmail.com>
Subject Re: [VOTE] Drop Java 5 support for trunk (Lucene 4.0)
Date Tue, 28 Jun 2011 21:30:03 GMT
+1 from old-stick-in-the-mud, whose vote does not count :)

BTW, today Apple released Java 1.5.0_30. So while Oracle has not 
supplied security updates or bug fixes to 1.5 since Nov 2009, except to 
premier customers, Apple is still actively supporting it for OS X 10.5, 
Leopard.

On 06/28/2011 10:48 AM, Robert Muir wrote:
> +1!
>
> but, who are you and what have you done with our generics policeman?! :)
>
> On Mon, Jun 27, 2011 at 1:45 PM, Uwe Schindler<uwe@thetaphi.de>  wrote:
>> My +1 for trunk :-)
>>
>> I will change hudson scripts once this vote passes!
>>
>> -----
>> Uwe Schindler
>> H.-H.-Meier-Allee 63, D-28213 Bremen
>> http://www.thetaphi.de
>> eMail: uwe@thetaphi.de
>>
>>
>>> -----Original Message-----
>>> From: Simon Willnauer [mailto:simon.willnauer@googlemail.com]
>>> Sent: Monday, June 27, 2011 7:38 PM
>>> To: dev@lucene.apache.org
>>> Subject: [VOTE] Drop Java 5 support for trunk (Lucene 4.0)
>>>
>>> This issue has been discussed on various occasions and lately on
>>> LUCENE-3239 (https://issues.apache.org/jira/browse/LUCENE-3239)
>>>
>>> The main reasons for this have been discussed on the issue but let me put
>>> them out here too:
>>>
>>> - Lack of testing on Jenkins with Java 5
>>> - Java 5 end of lifetime is reached a long time ago so Java 5 is totally
>>> unmaintained which means for us that bugs have to either be hacked
>>> around, tests disabled, warnings placed, but some things simply cannot be
>>> fixed... we cannot actually "support" something that is no longer maintained:
>>> we do find JRE bugs
>>> (http://wiki.apache.org/lucene-java/SunJavaBugs) and its important that
>>> bugs actually get fixed: cannot do everything with hacks.\
>>> - due to Java 5 we legitimate performance hits like 20% slower grouping
>>> speed.
>>>
>>> For reference please read through the issue mentioned above.
>>>
>>> A lot of the committers seem to be on the same page here to drop Java
>>> 5 support so I am calling out an official vote.
>>>
>>> all Lucene 3.x releases will remain with Java 5 support this vote is for trunk
>>> only.
>>>
>>>
>>> Here is my +1
>>>
>>> Simon
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org For additional
>>> commands, e-mail: dev-help@lucene.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: dev-help@lucene.apache.org
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message