lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (LUCENE-3226) rename SegmentInfos.FORMAT_3_1 and improve description in CheckIndex
Date Fri, 24 Jun 2011 13:30:47 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-3226?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shai Erera resolved LUCENE-3226.
--------------------------------

       Resolution: Fixed
    Fix Version/s: 3.4
         Assignee: Shai Erera
    Lucene Fields: [New, Patch Available]  (was: [New])

Committed revision 1139284 (trunk).
Committed revision 1139286 (3x).
Committed revision 1139300 (3.3).

Thanks Robert and Mike for the review !

> rename SegmentInfos.FORMAT_3_1 and improve description in CheckIndex
> --------------------------------------------------------------------
>
>                 Key: LUCENE-3226
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3226
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.1, 3.2
>            Reporter: Hoss Man
>            Assignee: Shai Erera
>             Fix For: 3.3, 3.4, 4.0
>
>         Attachments: LUCENE-3226.patch, LUCENE-3226.patch, LUCENE-3226.patch
>
>
> A 3.2 user recently asked if something was wrong because CheckIndex was reporting his
(newly built) index version as...
> {noformat}
> Segments file=segments_or numSegments=1 version=FORMAT_3_1 [Lucene 3.1]
> {noformat}
> It seems like there are two very confusing pieces of information here...
> 1) the variable name of SegmentInfos.FORMAT_3_1 seems like poor choice.  All other FORMAT_*
constants in SegmentInfos are descriptive of the actual change made, and not specific to the
version when they were introduced.
> 2) whatever the name of the FORMAT_* variable, CheckIndex is labeling it "Lucene 3.1",
which is missleading since that format is alwasy used in 3.2 (and probably 3.3, etc...). 

> I suggest:
> a) rename FORMAT_3_1 to something like "FORMAT_SEGMENT_RECORDS_VERSION"
> b) change CheckIndex so that the label for the "newest" format always ends with " and
later" (ie: "Lucene 3.1 and later") so when we release versions w/o a format change we don't
have to remember to manual list them in CheckIndex.  when we *do* make format changes and
update CheckIndex " and later" can be replaced with " to X.Y" and the new format can be added

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message