lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3226) rename SegmentInfos.FORMAT_3_1 and improve description in CheckIndex
Date Thu, 23 Jun 2011 10:44:47 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13053784#comment-13053784
] 

Michael McCandless commented on LUCENE-3226:
--------------------------------------------

Can we have the constant name be descriptive (reflect what actually changed) and then add
a comment expressing the version when that change was made to Lucene?

I think we should name them primarily for the benefit of developers working with the source
code going forward, and only secondarily for the future developer who will some day need to
remove them...

> rename SegmentInfos.FORMAT_3_1 and improve description in CheckIndex
> --------------------------------------------------------------------
>
>                 Key: LUCENE-3226
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3226
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.1, 3.2
>            Reporter: Hoss Man
>             Fix For: 3.3, 4.0
>
>         Attachments: LUCENE-3226.patch
>
>
> A 3.2 user recently asked if something was wrong because CheckIndex was reporting his
(newly built) index version as...
> {noformat}
> Segments file=segments_or numSegments=1 version=FORMAT_3_1 [Lucene 3.1]
> {noformat}
> It seems like there are two very confusing pieces of information here...
> 1) the variable name of SegmentInfos.FORMAT_3_1 seems like poor choice.  All other FORMAT_*
constants in SegmentInfos are descriptive of the actual change made, and not specific to the
version when they were introduced.
> 2) whatever the name of the FORMAT_* variable, CheckIndex is labeling it "Lucene 3.1",
which is missleading since that format is alwasy used in 3.2 (and probably 3.3, etc...). 

> I suggest:
> a) rename FORMAT_3_1 to something like "FORMAT_SEGMENT_RECORDS_VERSION"
> b) change CheckIndex so that the label for the "newest" format always ends with " and
later" (ie: "Lucene 3.1 and later") so when we release versions w/o a format change we don't
have to remember to manual list them in CheckIndex.  when we *do* make format changes and
update CheckIndex " and later" can be replaced with " to X.Y" and the new format can be added

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message