lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Willnauer (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3084) MergePolicy.OneMerge.segments should be List<SegmentInfo> not SegmentInfos
Date Thu, 12 May 2011 06:39:50 GMT


Simon Willnauer commented on LUCENE-3084:

bq. Let's stop subclassing random things? : ) SIS can contain a List of SIs (and maybe a Set,
or whatever we need in the future), and only expose operations its clients really need
+1 we should if at all implement Iterable<SegmentInfo> instead of vector or arraylist.

bq. I would love to cutover to Set<SI>, but, I don't think we can. There are apps out
there that want merges to remain contiguous (so docIDs keep their monotonicity).

I think this should be feasible with a sorted set? It might make sense is the SIS case to
hold a NavigableSet and I personally would prever that much over subclassing some random collection.
If we refactor this we should refactor towards an interface not an implementation.

> MergePolicy.OneMerge.segments should be List<SegmentInfo> not SegmentInfos
> --------------------------------------------------------------------------
>                 Key: LUCENE-3084
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 3.2, 4.0
>         Attachments: LUCENE-3084-trunk-only.patch, LUCENE-3084-trunk-only.patch, LUCENE-3084.patch
> SegmentInfos carries a bunch of fields beyond the list of SI, but for merging purposes
these fields are unused.
> We should cutover to List<SI> instead.

This message is automatically generated by JIRA.
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message