lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3109) Rename FieldsConsumer to InvertedFieldsConsumer
Date Wed, 18 May 2011 17:42:48 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3109?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13035510#comment-13035510
] 

Michael McCandless commented on LUCENE-3109:
--------------------------------------------

+1

> Rename FieldsConsumer to InvertedFieldsConsumer
> -----------------------------------------------
>
>                 Key: LUCENE-3109
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3109
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: core/codecs
>    Affects Versions: 4.0
>            Reporter: Simon Willnauer
>            Priority: Minor
>             Fix For: 4.0
>
>
> The name FieldsConsumer is missleading here it really is an InvertedFieldsConsumer and
since we are extending codecs to consume non-inverted Fields we should be clear here. Same
applies to Fields.java as well as FieldsProducer.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message