lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (LUCENE-3014) comparator API for segment versions
Date Mon, 04 Apr 2011 23:35:05 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-3014?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Uwe Schindler reassigned LUCENE-3014:
-------------------------------------

    Assignee: Uwe Schindler

> comparator API for segment versions
> -----------------------------------
>
>                 Key: LUCENE-3014
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3014
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
>            Assignee: Uwe Schindler
>            Priority: Critical
>             Fix For: 3.2
>
>
> See LUCENE-3012 for an example.
> Things get ugly if you want to use SegmentInfo.getVersion()
> For example, what if we committed my patch, release 3.2, but later released 3.1.1 (will
"3.1.1" this be whats written and returned by this function?)
> Then suddenly we broke the index format because we are using Strings here without a reasonable
comparator API.
> In this case one should be able to compute if the version is < 3.2 safely.
> If we don't do this, and we rely upon this version information internally in lucene,
I think we are going to break something.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message