lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Kukačka <pavel.kuka...@seznam.cz>
Subject Highlighting in fields other than content
Date Fri, 29 Apr 2011 12:56:42 GMT
Hello,

	I've got a (probably trivial) issue I can't resolve with Solr 3.1: 
I have a document with common fields (title, keywords, content) and I'm
trying to use highlighting.
	With the content field there is no problem; works normally. However,
when I search for a document via its keyword, the document is found, but
the response doesn't have the highlighted snippet - there is only an
empty node - like this:
******************
.
.
.
<lst name="highlighting">
  <lst name="2008"/>
</lst>
</response>
************************

As for the highlighting params, I have set:
	hl=on
	hl.fl=*


If I just substitute the searchterm for something from the content, the
resulting response is fine - like this:
************************************
.
.
.
<lst name="2008">
  <arr name="content">
    <str>
 ustanoven&#237; t&#283;chto VOP, ZOP, smlouvy &#269;i  <em
id="highlighting">dru&#382;stvem</em> na stran&#283; jedn&#233; a
Klienty na stran&#283; druh&#233; 
na jin&#233;ho
    </str>
.
.
.
************************************

Does anyone see what I've omitted?

Cheers,
Pavel


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message