lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Male <gento...@gmail.com>
Subject Re: [jira] Updated: (LUCENE-2308) Separately specify a field's type
Date Fri, 11 Mar 2011 03:35:41 GMT
I'm still likely to take a shot at this myself, assuming someone from GSOC
doesn't whip up something first.

On Fri, Mar 11, 2011 at 7:25 AM, Michael McCandless (JIRA)
<jira@apache.org>wrote:

>
>     [
> https://issues.apache.org/jira/browse/LUCENE-2308?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel]
>
> Michael McCandless updated LUCENE-2308:
> ---------------------------------------
>
>    Labels: gsoc2011 lucene-gsoc-11  (was: )
>
> > Separately specify a field's type
> > ---------------------------------
> >
> >                 Key: LUCENE-2308
> >                 URL: https://issues.apache.org/jira/browse/LUCENE-2308
> >             Project: Lucene - Java
> >          Issue Type: Improvement
> >          Components: Index
> >            Reporter: Michael McCandless
> >              Labels: gsoc2011, lucene-gsoc-11
> >             Fix For: 4.0
> >
> >
> > This came up from dicussions on IRC.  I'm summarizing here...
> > Today when you make a Field to add to a document you can set things
> > index or not, stored or not, analyzed or not, details like omitTfAP,
> > omitNorms, index term vectors (separately controlling
> > offsets/positions), etc.
> > I think we should factor these out into a new class (FieldType?).
> > Then you could re-use this FieldType instance across multiple fields.
> > The Field instance would still hold the actual value.
> > We could then do per-field analyzers by adding a setAnalyzer on the
> > FieldType, instead of the separate PerFieldAnalzyerWrapper (likewise
> > for per-field codecs (with flex), where we now have
> > PerFieldCodecWrapper).
> > This would NOT be a schema!  It's just refactoring what we already
> > specify today.  EG it's not serialized into the index.
> > This has been discussed before, and I know Michael Busch opened a more
> > ambitious (I think?) issue.  I think this is a good first baby step.  We
> could
> > consider a hierarchy of FIeldType (NumericFieldType, etc.) but maybe hold
> > off on that for starters...
>
> --
> This message is automatically generated by JIRA.
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>


-- 
Chris Male | Software Developer | JTeam BV.| www.jteam.nl

Mime
View raw message