lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (LUCENE-2957) generate-maven-artifacts target should include all non-Mavenized Lucene & Solr dependencies
Date Thu, 10 Mar 2011 22:38:05 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2957?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13005363#comment-13005363
] 

Steven Rowe edited comment on LUCENE-2957 at 3/10/11 10:37 PM:
---------------------------------------------------------------

Patch against trunk implementing the changes.

This patch also marks the local patched versions of the {{jetty}} and {{jetty-util}} Solr
dependencies as optional, so that they will be available for compilation and testing, but
will not be published and will not trigger transitive resolution of the dependencies for projects
that depend on solr-core (including the Solr {{.war}}, which should not contain these {{.jar}}'s).

      was (Author: steve_rowe):
    Patch against trunk implementing the changes.

This patch also marks the local patched versions of the jetty and jetty-uril Solr dependencies
as optional, so that they will be available for compilation and testing, but will not be published
and will not trigger transitive resolution of the dependency for projects that depend on solr-core
(including the Solr .war, which should not contain these .jars).
  
> generate-maven-artifacts target should include all non-Mavenized Lucene & Solr dependencies
> -------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-2957
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2957
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 3.1, 3.2, 4.0
>            Reporter: Steven Rowe
>            Priority: Minor
>             Fix For: 3.1, 3.2, 4.0
>
>         Attachments: LUCENE-2957.patch
>
>
> Currently, in addition to deploying artifacts for all of the Lucene and Solr modules
to a repository (by default local), the {{generate-maven-artifacts}} target also deploys artifacts
for the following non-Mavenized Solr dependencies (lucene_solr_3_1 version given here):
> # {{solr/lib/commons-csv-1.0-SNAPSHOT-r966014.jar}} as org.apache.solr:solr-commons-csv:3.1
> # {{solr/lib/apache-solr-noggit-r944541.jar}} as org.apache.solr:solr-noggit:3.1
> \\ \\
> The following {{.jar}}'s should be added to the above list (lucene_solr_3_1 version given
here):
> \\ \\
> # {{lucene/contrib/icu/lib/icu4j-4_6.jar}}
> # {{lucene/contrib/benchmark/lib/xercesImpl-2.9.1-patched-XERCESJ}}{{-1257.jar}}
> # {{solr/contrib/clustering/lib/carrot2-core-3.4.2.jar}}**
> # {{solr/contrib/uima/lib/uima-an-alchemy.jar}}
> # {{solr/contrib/uima/lib/uima-an-calais.jar}}
> # {{solr/contrib/uima/lib/uima-an-tagger.jar}}
> # {{solr/contrib/uima/lib/uima-an-wst.jar}}
> # {{solr/contrib/uima/lib/uima-core.jar}}
> \\ \\
> I think it makes sense to follow the same model as the current non-Mavenized dependencies:
> \\ \\
> * {{groupId}} = {{org.apache.solr/.lucene}}
> * {{artifactId}} = {{solr-/lucene-}}<original-name>,
> * {{version}} = <lucene-solr-release-version>.
> **The carrot2-core jar doesn't need to be included in trunk's release artifacts, since
there already is a Mavenized Java6-compiled jar.  branch_3x and lucene_solr_3_1 will need
this Solr-specific Java5-compiled maven artifact, though.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message