lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "karthik (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SOLR-1987) java.lang.VerifyError runtime exception in Solr 1.4.1 when trying to run solr in Embedded mode
Date Fri, 11 Mar 2011 07:26:59 GMT

    [ https://issues.apache.org/jira/browse/SOLR-1987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13005534#comment-13005534
] 

karthik commented on SOLR-1987:
-------------------------------

I am still facing this issue:

The environment is jdk1.6_24 and trying to deploy my application in jboss6. But the same app
ran well under jboss5 and jdk1.6_24. 

I did not understand the reason for the VerifyError since the jdk1.6_24 remained the same
in both the cases. 

> java.lang.VerifyError runtime exception in Solr 1.4.1 when trying to run solr in Embedded
mode
> ----------------------------------------------------------------------------------------------
>
>                 Key: SOLR-1987
>                 URL: https://issues.apache.org/jira/browse/SOLR-1987
>             Project: Solr
>          Issue Type: Bug
>          Components: clients - java
>    Affects Versions: 1.4.1
>         Environment: Windows 7
>            Reporter: Ravish Bhagdev
>             Fix For: Next
>
>
> When trying to run solr in embedded mode:
>             CoreContainer.Initializer initializer = new CoreContainer.Initializer();
>             CoreContainer coreContainer = initializer.initialize();
>             server = new EmbeddedSolrServer(coreContainer, "");
> An exception is thrown in version 1.4.1, here is the stacktrace: 
> java.lang.VerifyError: class org.apache.solr.search.SolrIndexReader overrides final method
setNorm.(ILjava/lang/String;B)V
> 	at java.lang.ClassLoader.defineClass1(Native Method)
> 	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
> 	at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
> 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
> 	at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2527)
> 	at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1010)
> 	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1483)
> 	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1361)
> 	at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:166)
> 	at org.apache.solr.core.CoreContainer$Initializer.initialize(CoreContainer.java:134)
> It may be a class version issue with the released zip source code, but I am not sure.
 It looks like the release was not compiled properly?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message