lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1391) Token type and flags values get lost when using ShingleMatrixFilter
Date Tue, 01 Feb 2011 01:58:29 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12989003#comment-12989003
] 

Robert Muir commented on LUCENE-1391:
-------------------------------------

Uwe, do you think we will have time to fix this for 3.1?

The issue has been around for a while, also a similar issue exists in contrib/compounds.
In both cases we have documentation:
{noformat}
 * <b>NOTE:</b> This filter might not behave correctly if used with custom Attributes,
i.e. Attributes other than
 * the ones located in org.apache.lucene.analysis.tokenattributes.
{noformat}


> Token type and flags values get lost when using ShingleMatrixFilter
> -------------------------------------------------------------------
>
>                 Key: LUCENE-1391
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1391
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: contrib/analyzers
>    Affects Versions: 2.4, 2.9, 3.0
>            Reporter: Wouter Heijke
>            Assignee: Uwe Schindler
>             Fix For: 3.1, 4.0
>
>
> While using the new ShingleMatrixFilter I noticed that a token's type and flags get lost
while using this filter. ShingleFilter does respect these values like the other filters I
know.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message