lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-2694) MTQ rewrite + weight/scorer init should be single pass
Date Tue, 21 Dec 2010 11:45:02 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12973591#action_12973591
] 

Michael McCandless commented on LUCENE-2694:
--------------------------------------------

Patch looks awesome!

Really, ord() support is a function of the terms dict impl, not the
codec (well, indirectly codec has ord() support if its terms dict impl
does).  PrefixCodedTermsDict, in turn, supports ord() only if its
terms index does.

Can we move TermStateBase (now under codecs.standard) up into codecs
and rename it to PrefixCodedTermState?  Ie, it's awkward that
PrefixCodedTermsReader (a terms dict impl shared across many codecs)
is reaching into standard codec to get its TermState impl.  Then, the
private static class in StandardPostingsReader can be renamed to
StandardTermState?

I like this new ReaderView!  I think it can be more generally useful
outside of PerReaderTermState, eg Filter/Collector could receive this
so that they can map sub reader to context in parent.  But let's leave
that for another day.

Still some small whitespace issues, eg if(


> MTQ rewrite + weight/scorer init should be single pass
> ------------------------------------------------------
>
>                 Key: LUCENE-2694
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2694
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 4.0
>
>         Attachments: LUCENE-2694-FTE.patch, LUCENE-2694.patch, LUCENE-2694.patch, LUCENE-2694.patch,
LUCENE-2694.patch, LUCENE-2694.patch
>
>
> Spinoff of LUCENE-2690 (see the hacked patch on that issue)...
> Once we fix MTQ rewrite to be per-segment, we should take it further and make weight/scorer
init also run in the same single pass as rewrite.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message