lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adeelmahmood <adeelmahm...@gmail.com>
Subject running solr unit tests in eclipse
Date Mon, 20 Dec 2010 14:49:47 GMT

I am not sure if I am able to run the unit tests for solr in eclipse .. If i
just ran the build.xml with test arg .. it runs all the tests and shows that
they are successful and all that .. very few fail though .. but more
importantly if i wanna run a single testcase by
-Dtestcase=org.apache.solr.request.TestFaceting.testFacets clean test
arg .. then it does all the compile steps but for the actual test it doesnt
shows any output .. in terms of whether the test was successful or not ..
here is the output
......
compile:
compileTests:
    [mkdir] Created dir:
C:\Users\Adeel\Documents\workspace-sts-2.5.1.RELEASE\solr\contrib\extraction\build\test-classes
    [javac] Compiling 1 source file to
C:\Users\Adeel\Documents\workspace-sts-2.5.1.RELEASE\solr\contrib\extraction\build\test-classes
test:
test:
BUILD SUCCESSFUL
Total time: 4 minutes 44 seconds

I am not even sure if the test is really running .. also why cant I just run
the test directly by clicking on the class and Run the method as junit test
case ..

Thanks for your help
Adeel 
-- 
View this message in context: http://lucene.472066.n3.nabble.com/running-solr-unit-tests-in-eclipse-tp2120574p2120574.html
Sent from the Solr - Dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message