lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-2774) ant generate-maven-artifacts target broken for contrib
Date Mon, 22 Nov 2010 13:52:13 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2774?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12934464#action_12934464
] 

Steven Rowe commented on LUCENE-2774:
-------------------------------------

Hi Drew,

I tried running {{ant generate-maven-artifacts}} without your patch, and I see the same failure
as you do.

(Actually, when I first tried, with Ant 1.8.1, it wasn't able to find the maven ant tasks
jar (the most recent) that I had placed in {{$ANT_HOME/lib/}} - I downgraded to Ant 1.7.0
and everything went fine.  Apparently Ant 1.8.X no longer pays attention to jars in {{$ANT_HOME/lib/}}?)

However, after applying your patch, the build still fails on trunk (haven't tried branch_3x
yet), though not with the same failure.

(Ant 1.7.0, Sun JDK 1.6.0_13 on Cygwin/WinVista):

{noformat}
BUILD FAILED
C:\cygwin\home\us\svn\lucene\dev\trunk\lucene\build.xml:396: The following error occurred
while executing this line:
C:\cygwin\home\us\svn\lucene\dev\trunk\lucene\common-build.xml:324: Error deploying artifact
'org.apache.lucene:lucene-core:jar': Error deploying artifact: 
File C:\cygwin\home\us\svn\lucene\dev\trunk\lucene\build\${project.artifactId}-${project.version}.jar
does not exist
{noformat}

Looks like some kind of failed interpolation maybe?

I'm going to try under Linux later today.

> ant generate-maven-artifacts target broken for contrib
> ------------------------------------------------------
>
>                 Key: LUCENE-2774
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2774
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 3.1, 4.0
>            Reporter: Drew Farris
>            Priority: Minor
>         Attachments: LUCENE-2774.patch
>
>
> When executing 'ant generate-maven-artifacts' from a pristine checkout of branch_3x/lucene
or trunk/lucene the following error is encountered:
> {code}
> dist-maven:
>      [copy] Copying 1 file to /home/drew/lucene/branch_3x/lucene/build/contrib/analyzers/common
> [artifact:install-provider] Installing provider: org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
> [artifact:pom] An error has occurred while processing the Maven artifact tasks.
> [artifact:pom]  Diagnosis:
> [artifact:pom] 
> [artifact:pom] Unable to initialize POM pom.xml.template: Cannot find parent: org.apache.lucene:lucene-contrib
for project: org.apache.lucene:lucene-analyzers:jar:3.1-SNAPSHOT for project org.apache.lucene:lucene-analyzers:jar:3.1-SNAPSHOT
> [artifact:pom] Unable to download the artifact from any repository
> {code}
> The contrib portion of the ant build is executed in a subant task which does not pick
up the pom definitions for lucene-parent and lucene-contrib from the main build.xml, so the
lucene-parent and lucene-controb poms must be loaded specifically as a part of the contrib
build using the artifact:pom task.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message