lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gérard Dupont <ger.dup...@gmail.com>
Subject Re: Error while building maven artifacts
Date Fri, 29 Oct 2010 08:10:11 GMT
Hi Uwe,

Thanks for the prompt answer. Indeed I know that trunk sources are not
stable, but I'm interested in testing the CoOcurrence module just added end
of August (https://issues.apache.org/jira/browse/LUCENE-474) on my current
corpus. Thus my need to build the trunk. I tried that but I though some
modules where mandatory and I tried to make it work... Well, I'll try to
build only Lucene then SolR separately.

tnks

On 29 October 2010 10:04, Uwe Schindler <uwe@thetaphi.de> wrote:

> Maven build for global Lucene/Solr is broken and not yet working. You can
> only build maven from inside the solr/ folder or lucene/ folder. For
> modules/ folder (analyzers) it does not work at all. Please note that trunk
> is development code and not guaranteed to work correctly. I would suggest to
> use the 3.x branch (where you also have to build artifacts for Lucene and
> Solr separately), only if you are interested in flexible indexing use trunk.
>
>
>
> The latest maven artifacts for Lucene or Solr can be downloaded also from
> https://hudson.apache.org/hudson/computer/lucene/, please choose job and
> go to artifacts.
>
>
>
> -----
>
> Uwe Schindler
>
> H.-H.-Meier-Allee 63, D-28213 Bremen
>
> http://www.thetaphi.de
>
> eMail: uwe@thetaphi.de
>
>
>
> *From:* Gérard Dupont [mailto:ger.dupont@gmail.com]
> *Sent:* Friday, October 29, 2010 9:46 AM
> *To:* dev@lucene.apache.org
> *Subject:* Error while building maven artifacts
>
>
>
> Dear All,
>
>
>
> I cannot build the maven articfact for the last version of lucene-solr
> (commit 1028633). Ant is complaining about the pom parent template for
> Lucene:
>
>
>
> BUILD FAILED
>
> /home/litis/Documents/dev/luceneSolR/build.xml:46: The following error
> occurred while executing this line:
>
> /home/litis/Documents/dev/luceneSolR/lucene/build.xml:406: The following
> error occurred while executing this line:
>
> /home/litis/Documents/dev/luceneSolR/lucene/build.xml:545: The following
> error occurred while executing this line:
>
> /home/litis/Documents/dev/luceneSolR/lucene/contrib/contrib-build.xml:80:
> The following error occurred while executing this line:
>
> /home/litis/Documents/dev/luceneSolR/lucene/common-build.xml:322: Unable to
> initialize POM pom.xml.template: Cannot find parent:
> org.apache.lucene:lucene-contrib for project:
> org.apache.lucene:lucene-ant:jar:4.0-SNAPSHOT for project
> org.apache.lucene:lucene-ant:jar:4.0-SNAPSHOT
>
>
>
> The lucene-parent-pom.xml.template is present and it seams to work while
> generating the actual pom but it is not installed in my maven repository.
> Any clue how to solve this ?
>
>
>
> --
>
> Gérard Dupont
>
> Information Processing Control and Cognition (IPCC)
>
> CASSIDIAN - an EADS company
>
>
>
> Document & Learning team - LITIS Laboratory
>



-- 
Gérard Dupont
Information Processing Control and Cognition (IPCC)
CASSIDIAN - an EADS company

Document & Learning team - LITIS Laboratory

Mime
View raw message