lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <yo...@lucidimagination.com>
Subject Re: solr build fails with java 1.5
Date Sat, 23 Oct 2010 12:19:11 GMT
Solr trunk (4.0-dev) requires Java6, as does zookeeper, a new Solr dependency.
Not much we can do about it.
Java6 has been out for almost 4 years now though, so it's not an
unrealistic requirement either.

-Yonik
http://www.lucidimagination.com

On Sat, Oct 23, 2010 at 2:13 AM, abhayd <ajdabholkar@hotmail.com> wrote:
>
> hi
> i downloaded solr trunk and was trying to build using jdk 1.5.
>
> I keep getting error
>     [echo] Java Runtime Environment          version: 1.5.0_22
>    [javac] Compiling 1 source file to
> C:\search\workspace\solr\solr\build\solr
>    [javac] javac: invalid target release: 1.6
>
> I am using eclipse
>
> I can compile with 1.6 fine, but our production is at 1.5.
>
> Any thoughts?
> --
> View this message in context: http://lucene.472066.n3.nabble.com/solr-build-fails-with-java-1-5-tp1756553p1756553.html
> Sent from the Solr - Dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message