lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] Updated: (SOLR-2118) IndexReaderFactory.setTermIndexInterval is misleading and confusing
Date Sun, 12 Sep 2010 20:04:33 GMT

     [ https://issues.apache.org/jira/browse/SOLR-2118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Muir updated SOLR-2118:
------------------------------

    Attachment: SOLR-2118.patch

attached is a patch, with all examples and other solrconfigs in test-files set back to setTermIndexDivisor
as it was in Solr 1.4

I think this is important, if someone depends on this currently in 1.4 and tries out 3.x or
trunk, they might get OOM since it wont be respected.

So, i'd like to commit this at the end of the day if there are no objections.

Separately, i agree it would be better if this sat with the other related index variables
in the solrconfig, but I think thats for another issue.


> IndexReaderFactory.setTermIndexInterval is misleading and confusing
> -------------------------------------------------------------------
>
>                 Key: SOLR-2118
>                 URL: https://issues.apache.org/jira/browse/SOLR-2118
>             Project: Solr
>          Issue Type: Bug
>          Components: search
>    Affects Versions: 3.1, 4.0
>            Reporter: Robert Muir
>             Fix For: 3.1, 4.0
>
>         Attachments: SOLR-2118.patch, SOLR-2118.patch
>
>
> To change the terms index divisor: you currently do this:
> {noformat}
>   <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
>     <int name="setTermIndexInterval">12</int>
>   </indexReaderFactory >
> {noformat}
> But to change the terms index interval, you do this:
> {noformat}
> <indexDefaults>
> ...
> <termIndexInterval>256</termIndexInterval>
> ...
> </indexDefaults>
> {noformat}
> I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
> the name is very misleading and someone could easily put a terrible value 
> in the wrong place by confusing the two.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message