lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SOLR-2118) IndexReaderFactory.setTermIndexInterval is misleading and confusing
Date Sun, 12 Sep 2010 12:17:32 GMT

    [ https://issues.apache.org/jira/browse/SOLR-2118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12908450#action_12908450
] 

Robert Muir commented on SOLR-2118:
-----------------------------------

bq. Setting the divisor that way shouldn't likely work on trunk anymore, since Lucene dropped
it. That is just a generic 'call this bean method' system.

I am not referring to the IW parameter, but the IR param. The IR param is named termIndex
*Interval* but is really the terms index *divisor*, this is what I feel is misleading and
confusing.

just look at Solr's IndexReaderFactory to see:

{noformat}
Integer v = (Integer)args.get("setTermIndexInterval");
    if (v != null) {
      termInfosIndexDivisor = v.intValue();
    }
{noformat}


> IndexReaderFactory.setTermIndexInterval is misleading and confusing
> -------------------------------------------------------------------
>
>                 Key: SOLR-2118
>                 URL: https://issues.apache.org/jira/browse/SOLR-2118
>             Project: Solr
>          Issue Type: Improvement
>          Components: search
>    Affects Versions: 1.4
>            Reporter: Robert Muir
>             Fix For: 3.1, 4.0
>
>
> To change the terms index divisor: you currently do this:
> {noformat}
>   <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
>     <int name="setTermIndexInterval">12</int>
>   </indexReaderFactory >
> {noformat}
> But to change the terms index interval, you do this:
> {noformat}
> <indexDefaults>
> ...
> <termIndexInterval>256</termIndexInterval>
> ...
> </indexDefaults>
> {noformat}
> I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
> the name is very misleading and someone could easily put a terrible value 
> in the wrong place by confusing the two.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message