lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Willnauer (JIRA)" <>
Subject [jira] Commented: (SOLR-2118) IndexReaderFactory.setTermIndexInterval is misleading and confusing
Date Sun, 12 Sep 2010 19:37:32 GMT


Simon Willnauer commented on SOLR-2118:

bq. Seems like both the interval and the divisor could belong as properties of the index (i.e.
the mainIndex section of solrconfig.xml)?

I agree, IMO we should try to keep TermIndexInterval and Divisor together both should be settable
in the <indexDefaults> section 
Additionally overriding those in a IndexReaderFactory section seems to be reasonable to me.
question, is it possible to have more than one IR factory and use them in different places,
I can't think of one from the top of my head since I never saw that param before?

If we enable setting IndexDivisor values in indexReaderFactory sections do we need to have
the {{set}} prefix? <int name=:TermIndexDivisor">1</int> seems to be nicer or
is this a set via reflection to a bean setter?

Regarding the patch, we should also change it in Example conf in {{solr/example/solr/conf/solrconfig.xml}}

> IndexReaderFactory.setTermIndexInterval is misleading and confusing
> -------------------------------------------------------------------
>                 Key: SOLR-2118
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>          Components: search
>    Affects Versions: 1.4
>            Reporter: Robert Muir
>             Fix For: 3.1, 4.0
>         Attachments: SOLR-2118.patch
> To change the terms index divisor: you currently do this:
> {noformat}
>   <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
>     <int name="setTermIndexInterval">12</int>
>   </indexReaderFactory >
> {noformat}
> But to change the terms index interval, you do this:
> {noformat}
> <indexDefaults>
> ...
> <termIndexInterval>256</termIndexInterval>
> ...
> </indexDefaults>
> {noformat}
> I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
> the name is very misleading and someone could easily put a terrible value 
> in the wrong place by confusing the two.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message