lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Willnauer (JIRA)" <>
Subject [jira] Commented: (LUCENE-2647) Move & rename the terms dict, index, abstract postings out of oal.index.codecs.standard
Date Thu, 16 Sep 2010 10:34:33 GMT


Simon Willnauer commented on LUCENE-2647:

Mike, I think renaming is a good idea - that might make things slightly easier for folks to
play around with codec 

here are some comments on the naming:

bq.StandardTermsDictWriter/Reader -> PrefixCodedTermsWriter/Reader

bq. StandardTermsIndexWriter/Reader -> AbstractTermsIndexWriter/Reader
What about TermsIndexWriter/ReaderBase since we started using that scheme with analyzers and
the JDK uses that too. If we remove the abstractness one day the name is very miss-leading
but the property of being a base class will likely remain.

bq. SimpleStandardTermsIndexWriter/Reader -> SimpleTermsIndexWriter/Reader
I really don't like Simple* its like Smart which makes me immediately feel itchy all over
the place. What differentiates this from others? It is the default? maybe DefaultTermsIndexWriter/Reader?

bq. StandardPostingsWriter/Reader -> AbstractPostingsWriter/Reader
Again, what about PostingWriter/ReaderBase

bq. StandardPostingsWriterImpl/ReaderImple -> StandardPostingsWriter/Reader

> Move & rename the terms dict, index, abstract postings out of oal.index.codecs.standard
> ---------------------------------------------------------------------------------------
>                 Key: LUCENE-2647
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 4.0
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>         Attachments: LUCENE-2647.patch
> The terms dict components that current live under Standard codec
> (oal.index.codecs.standard.*) are in fact very generic, and in no way
> particular to the Standard codec.  Already we have many other codecs
> (sep, fixed int block, var int block, pulsing, appending) that re-use
> the terms dict writer/reader components.
> So I'd like to move these out into oal.index.codecs, and rename them:
>   * StandardTermsDictWriter/Reader -> PrefixCodedTermsWriter/Reader
>   * StandardTermsIndexWriter/Reader -> AbstractTermsIndexWriter/Reader
>   * SimpleStandardTermsIndexWriter/Reader -> SimpleTermsIndexWriter/Reader
>   * StandardPostingsWriter/Reader -> AbstractPostingsWriter/Reader
>   * StandardPostingsWriterImpl/ReaderImple -> StandardPostingsWriter/Reader
> With this move we have a nice reusable terms dict impl.  The terms
> index impl is still well-decoupled so eg we could [in theory] explore
> a variable gap terms index.
> Many codecs, I expect, don't need/want to implement their own terms
> dict....
> There are no code/index format changes here, besides the renaming &
> fixing all imports/usages of the renamed class.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message