lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SOLR-2118) IndexReaderFactory.setTermIndexInterval is misleading and confusing
Date Sun, 12 Sep 2010 14:09:32 GMT

    [ https://issues.apache.org/jira/browse/SOLR-2118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12908469#action_12908469
] 

Yonik Seeley commented on SOLR-2118:
------------------------------------

Yeah, definitely a bug.

Seems like both the interval and the divisor could belong as properties of the index (i.e.
the mainIndex section of solrconfig.xml)?
The current index reader factory architecture may not go where we need to go anyway actually...
for NRT, the writer(s) need to be involved?  Sort of outside of the scope of an immediate
fix for this issue - but something to think about.

> IndexReaderFactory.setTermIndexInterval is misleading and confusing
> -------------------------------------------------------------------
>
>                 Key: SOLR-2118
>                 URL: https://issues.apache.org/jira/browse/SOLR-2118
>             Project: Solr
>          Issue Type: Improvement
>          Components: search
>    Affects Versions: 1.4
>            Reporter: Robert Muir
>             Fix For: 3.1, 4.0
>
>
> To change the terms index divisor: you currently do this:
> {noformat}
>   <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
>     <int name="setTermIndexInterval">12</int>
>   </indexReaderFactory >
> {noformat}
> But to change the terms index interval, you do this:
> {noformat}
> <indexDefaults>
> ...
> <termIndexInterval>256</termIndexInterval>
> ...
> </indexDefaults>
> {noformat}
> I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
> the name is very misleading and someone could easily put a terrible value 
> in the wrong place by confusing the two.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message