lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] Created: (SOLR-2118) IndexReaderFactory.setTermIndexInterval is misleading and confusing
Date Sun, 12 Sep 2010 10:58:34 GMT
IndexReaderFactory.setTermIndexInterval is misleading and confusing

                 Key: SOLR-2118
             Project: Solr
          Issue Type: Improvement
          Components: search
    Affects Versions: 1.4
            Reporter: Robert Muir
             Fix For: 3.1, 4.0

To change the terms index divisor: you currently do this:

  <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
    <int name="setTermIndexInterval">12</int>
  </indexReaderFactory >

But to change the terms index interval, you do this:

I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
the name is very misleading and someone could easily put a terrible value 
in the wrong place by confusing the two.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message