lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shai Erera <ser...@gmail.com>
Subject Re: Build failed in Hudson: Lucene-trunk #1252
Date Tue, 10 Aug 2010 10:06:27 GMT
I've just replied suggesting to do the same thing :). Thanks Uwe for taking
care of that.

Though I'm still interested to hear why the build suddenly fails. Is this
due some new functionality?

Shai

On Tue, Aug 10, 2010 at 1:05 PM, Uwe Schindler <uwe@thetaphi.de> wrote:

> Fixed for both branches, I added a comment, why contrib-build.xml should
> *not* be imported here!
>
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
>
>
> > -----Original Message-----
> > From: Michael McCandless [mailto:lucene@mikemccandless.com]
> > Sent: Tuesday, August 10, 2010 11:07 AM
> > To: dev@lucene.apache.org
> > Subject: Re: Build failed in Hudson: Lucene-trunk #1252
> >
> > I think this failure may be from this commit:
> >
> > svn diff -c 980765
> >
> > Index: contrib/db/build.xml
> > ================================================================
> > ===
> > --- contrib/db/build.xml      (revision 980764)
> > +++ contrib/db/build.xml      (revision 980765)
> > @@ -25,6 +25,8 @@
> >        - bdb-je: using Berkeley DB Java Edition
> >    </description>
> >
> > +  <import file="../contrib-build.xml"/>
> > +
> >    <target name="bdb">
> >      <ant dir="bdb" />
> >    </target>
> >
> > The build fails because "ant jar-src" fails in contrib/db, which makes
> sense (you
> > have to run jar-src in the bdb, bdb-je subdirs).
> >
> > Any ideas?  Does contrib/db's build.xml really need to import
> contrib-build.xml?
> > (The 2 subdir's build.xml's already do).
> >
> > Mike
> >
> > On Mon, Aug 9, 2010 at 10:43 PM, Apache Hudson Server
> > <hudson@hudson.zones.apache.org> wrote:
> > > See
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/1252/changes>
> > >
> > > Changes:
> > >
> > > [rmuir] extend LuceneTestCase instead of Object here too
> > >
> > > [rmuir] SOLR-2002: add support for -Dtestmethod=xxx when running tests
> > >
> > > [rmuir] extend LuceneTestCase here instead
> > >
> > > [mikemccand] LUCENE-2589: allow ant command line property tests.codec
> > > to include param fr the codec
> > >
> > > [rmuir] SOLR-2002: change tests from TestCase to LuceneTestCase for
> > > better coverage
> > >
> > > [rmuir] SOLR-2002: change tests from TestCase to LuceneTestCase for
> > > better coverage
> > >
> > > ------------------------------------------
> > > [...truncated 9868 lines...]
> > > [artifact:deploy] Uploading:
> > > org/apache/lucene/lucene-core/4.0-SNAPSHOT/lucene-core-4.0-20100810.02
> > > 4256-1-javadoc.jar to remote [artifact:deploy] Uploaded 3138K
> > >     [copy] Copying 1 file to
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d> [artifact:install-provider] Installing provider:
> > > org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
> > > [artifact:pom] Error downloading parent pom org.apache.lucene:lucene-
> > parent::4.0-SNAPSHOT: Missing:
> > > [artifact:pom] ----------
> > > [artifact:pom] 1) org.apache.lucene:lucene-parent:pom:4.0-SNAPSHOT
> > > [artifact:pom]   Path to dependency:
> > > [artifact:pom]          1) unspecified:unspecified:jar:0.0
> > > [artifact:pom]          2)
> > > org.apache.lucene:lucene-parent:pom:4.0-SNAPSHOT
> > > [artifact:pom]
> > > [artifact:pom] ----------
> > > [artifact:pom] 1 required artifact is missing.
> > > [artifact:pom]
> > > [artifact:pom] for artifact:
> > > [artifact:pom]   unspecified:unspecified:jar:0.0 [artifact:pom]
> > > [artifact:pom] from the specified remote repositories:
> > > [artifact:pom]   central (http://repo1.maven.org/maven2)
> > > [artifact:deploy] Deploying to
> > > file://<http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/luce
> > > ne/dist/maven> [artifact:deploy] [INFO] Retrieving previous build
> > > number from remote [artifact:deploy] [INFO] repository metadata for:
> > > 'snapshot org.apache.lucene:lucene-contrib:4.0-SNAPSHOT' could not be
> > > found on repository: remote, so will be created [artifact:deploy]
> > > Uploading:
> > > org/apache/lucene/lucene-contrib/4.0-SNAPSHOT/lucene-contrib-4.0-20100
> > > 810.024256-1.pom to remote [artifact:deploy] Uploaded 2K
> > > [artifact:deploy] [INFO] Retrieving previous metadata from remote
> > [artifact:deploy] [INFO] repository metadata for: 'artifact
> > org.apache.lucene:lucene-contrib' could not be found on repository:
> remote, so
> > will be created [artifact:deploy] [INFO] Uploading repository metadata
> for:
> > 'artifact org.apache.lucene:lucene-contrib'
> > > [artifact:deploy] [INFO] Retrieving previous metadata from remote
> > > [artifact:deploy] [INFO] repository metadata for: 'snapshot
> > > org.apache.lucene:lucene-contrib:4.0-SNAPSHOT' could not be found on
> > repository: remote, so will be created [artifact:deploy] [INFO] Uploading
> > repository metadata for: 'snapshot org.apache.lucene:lucene-contrib:4.0-
> > SNAPSHOT'
> > >     [echo] Building ant...
> > >
> > > compile-analyzers-common:
> > >
> > > common.init:
> > >
> > > build-lucene:
> > >
> > > init:
> > >
> > > clover.setup:
> > >
> > > clover.info:
> > >
> > > clover:
> > >
> > > common.compile-core:
> > >
> > > compile-core:
> > >
> > > jar-src:
> > >      [jar] Building jar:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/ant/lucene-ant-4.0-SNAPSHOT-src.jar>
> > >
> > > dist-maven:
> > >     [copy] Copying 1 file to
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/ant> [artifact:install-provider] Installing provider:
> > > org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
> > > [artifact:pom] Error downloading parent pom org.apache.lucene:lucene-
> > contrib::4.0-SNAPSHOT: Missing:
> > > [artifact:pom] ----------
> > > [artifact:pom] 1) org.apache.lucene:lucene-contrib:pom:4.0-SNAPSHOT
> > > [artifact:pom]   Path to dependency:
> > > [artifact:pom]          1) unspecified:unspecified:jar:0.0
> > > [artifact:pom]          2)
> > > org.apache.lucene:lucene-contrib:pom:4.0-SNAPSHOT
> > > [artifact:pom]
> > > [artifact:pom] ----------
> > > [artifact:pom] 1 required artifact is missing.
> > > [artifact:pom]
> > > [artifact:pom] for artifact:
> > > [artifact:pom]   unspecified:unspecified:jar:0.0 [artifact:pom]
> > > [artifact:pom] from the specified remote repositories:
> > > [artifact:pom]   central (http://repo1.maven.org/maven2)
> > > [artifact:deploy] Deploying to
> > > file://<http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/luce
> > > ne/dist/maven> [artifact:deploy] [INFO] Retrieving previous build
> > > number from remote [artifact:deploy] [INFO] repository metadata for:
> > > 'snapshot org.apache.lucene:lucene-ant:4.0-SNAPSHOT' could not be
> > > found on repository: remote, so will be created [artifact:deploy]
> > > Uploading:
> > > org/apache/lucene/lucene-ant/4.0-SNAPSHOT/lucene-ant-4.0-20100810.0242
> > > 59-1.jar to remote [artifact:deploy] Uploaded 21K [artifact:deploy]
> > > [INFO] Retrieving previous metadata from remote [artifact:deploy]
> [INFO]
> > repository metadata for: 'artifact org.apache.lucene:lucene-ant' could
> not
> be
> > found on repository: remote, so will be created [artifact:deploy] [INFO]
> > Uploading repository metadata for: 'artifact
> org.apache.lucene:lucene-ant'
> > > [artifact:deploy] [INFO] Retrieving previous metadata from remote
> > > [artifact:deploy] [INFO] repository metadata for: 'snapshot
> > > org.apache.lucene:lucene-ant:4.0-SNAPSHOT' could not be found on
> > repository: remote, so will be created [artifact:deploy] [INFO] Uploading
> > repository metadata for: 'snapshot org.apache.lucene:lucene-ant:4.0-
> > SNAPSHOT'
> > > [artifact:deploy] [INFO] Uploading project information for lucene-ant
> > > 4.0-20100810.024259-1 [artifact:deploy] [INFO] Retrieving previous
> > > build number from remote [artifact:deploy] Uploading:
> > > org/apache/lucene/lucene-ant/4.0-SNAPSHOT/lucene-ant-4.0-20100810.0242
> > > 59-1-sources.jar to remote [artifact:deploy] Uploaded 20K
> > > [artifact:deploy] [INFO] Retrieving previous build number from remote
> > > [artifact:deploy] Uploading:
> > > org/apache/lucene/lucene-ant/4.0-SNAPSHOT/lucene-ant-4.0-20100810.0242
> > > 59-1-javadoc.jar to remote [artifact:deploy] Uploaded 68K
> > >     [echo] Building benchmark...
> > >
> > > common.init:
> > >
> > > compile-demo:
> > >
> > > compile-memory:
> > >
> > > compile-highlighter:
> > >
> > > compile-analyzers-common:
> > >
> > > init:
> > >
> > > clover.setup:
> > >
> > > clover.info:
> > >
> > > clover:
> > >
> > > compile-core:
> > >
> > > jar-src:
> > >      [jar] Building jar:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/benchmark/lucene-benchmark-4.0-SNAPSHOT-src.jar>
> > >
> > > dist-maven:
> > >     [copy] Copying 1 file to
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/benchmark> [artifact:install-provider] Installing provider:
> > > org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
> > > [artifact:pom] Error downloading parent pom org.apache.lucene:lucene-
> > contrib::4.0-SNAPSHOT: Missing:
> > > [artifact:pom] ----------
> > > [artifact:pom] 1) org.apache.lucene:lucene-contrib:pom:4.0-SNAPSHOT
> > > [artifact:pom]   Path to dependency:
> > > [artifact:pom]          1) unspecified:unspecified:jar:0.0
> > > [artifact:pom]          2)
> > > org.apache.lucene:lucene-contrib:pom:4.0-SNAPSHOT
> > > [artifact:pom]
> > > [artifact:pom] ----------
> > > [artifact:pom] 1 required artifact is missing.
> > > [artifact:pom]
> > > [artifact:pom] for artifact:
> > > [artifact:pom]   unspecified:unspecified:jar:0.0 [artifact:pom]
> > > [artifact:pom] from the specified remote repositories:
> > > [artifact:pom]   central (http://repo1.maven.org/maven2)
> > > [artifact:deploy] Deploying to
> > > file://<http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/luce
> > > ne/dist/maven> [artifact:deploy] [INFO] Retrieving previous build
> > > number from remote [artifact:deploy] [INFO] repository metadata for:
> > > 'snapshot org.apache.lucene:lucene-benchmark:4.0-SNAPSHOT' could not
> > > be found on repository: remote, so will be created [artifact:deploy]
> > > Uploading:
> > > org/apache/lucene/lucene-benchmark/4.0-SNAPSHOT/lucene-benchmark-
> > 4.0-2
> > > 0100810.024300-1.jar to remote [artifact:deploy] Uploaded 220K
> > > [artifact:deploy] [INFO] Retrieving previous metadata from remote
> > [artifact:deploy] [INFO] repository metadata for: 'snapshot
> > org.apache.lucene:lucene-benchmark:4.0-SNAPSHOT' could not be found on
> > repository: remote, so will be created [artifact:deploy] [INFO] Uploading
> > repository metadata for: 'snapshot
> org.apache.lucene:lucene-benchmark:4.0-
> > SNAPSHOT'
> > > [artifact:deploy] [INFO] Uploading project information for
> > > lucene-benchmark 4.0-20100810.024300-1 [artifact:deploy] [INFO]
> > > Retrieving previous metadata from remote [artifact:deploy] [INFO]
> > > repository metadata for: 'artifact org.apache.lucene:lucene-benchmark'
> > could not be found on repository: remote, so will be created
> [artifact:deploy]
> > [INFO] Uploading repository metadata for: 'artifact
> org.apache.lucene:lucene-
> > benchmark'
> > > [artifact:deploy] [INFO] Retrieving previous build number from remote
> > > [artifact:deploy] Uploading:
> > > org/apache/lucene/lucene-benchmark/4.0-SNAPSHOT/lucene-benchmark-
> > 4.0-2
> > > 0100810.024300-1-sources.jar to remote [artifact:deploy] Uploaded 201K
> > > [artifact:deploy] [INFO] Retrieving previous build number from remote
> > > [artifact:deploy] Uploading:
> > > org/apache/lucene/lucene-benchmark/4.0-SNAPSHOT/lucene-benchmark-
> > 4.0-2
> > > 0100810.024300-1-javadoc.jar to remote [artifact:deploy] Uploaded 679K
> > >     [echo] Building db...
> > >
> > > bdb:
> > >     [echo] Building bdb...
> > >
> > > common.init:
> > >
> > > build-lucene:
> > >
> > > contrib-build.init:
> > >
> > > get-db-jar:
> > >
> > > check-and-get-db-jar:
> > >
> > > init:
> > >
> > > clover.setup:
> > >
> > > clover.info:
> > >
> > > clover:
> > >
> > > compile-core:
> > >
> > > jar-core:
> > >      [jar] Building jar:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/db/lucene-db-4.0-SNAPSHOT.jar>
> > >
> > > default:
> > >
> > > bdb-je:
> > >     [echo] Building bdb-je...
> > >
> > > common.init:
> > >
> > > build-lucene:
> > >
> > > contrib-build.init:
> > >
> > > get-je-jar:
> > >
> > > check-and-get-je-jar:
> > >
> > > init:
> > >
> > > clover.setup:
> > >
> > > clover.info:
> > >
> > > clover:
> > >
> > > compile-core:
> > >
> > > jar-core:
> > >      [jar] Building jar:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-trunk/ws/lucene/buil
> > > d/contrib/db/lucene-db-4.0-SNAPSHOT.jar>
> > >
> > > default:
> > >
> > > default:
> > >
> > > dist-maven:
> > >     [echo] Building bdb...
> > >
> > > common.init:
> > >
> > > build-lucene:
> > >
> > > contrib-build.init:
> > >
> > > get-db-jar:
> > >
> > > check-and-get-db-jar:
> > >
> > > init:
> > >
> > > clover.setup:
> > >
> > > clover.info:
> > >
> > > clover:
> > >
> > > compile-core:
> > >
> > > jar-src:
> > >
> > > BUILD FAILED
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/build.xml>:406: The following error occurred while
> executing
> > this line:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/build.xml>:535: The following error occurred while
> executing
> > this line:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/contrib/db/build.xml>:60: The following error occurred
> while
> > executing this line:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/common-build.xml>:611: The following error occurred while
> > executing this line:
> > > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/common-build.xml>:368:
> > <http://hudson.zones.apache.org/hudson/job/Lucene-
> > trunk/ws/lucene/contrib/db/src/java> not found.
> > >
> > > Total time: 2 minutes 53 seconds
> > > [TASKS] Skipping publisher since build result is FAILURE Publishing
> > > Javadoc Archiving artifacts Recording test results Publishing Clover
> > > coverage report...
> > > No Clover report will be published due to a Build Failure
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> > > For additional commands, e-mail: dev-help@lucene.apache.org
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> > For additional commands, e-mail: dev-help@lucene.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>

Mime
View raw message