lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andi Vajda (JIRA)" <j...@apache.org>
Subject [jira] Created: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer
Date Fri, 09 Jul 2010 10:30:55 GMT
rename docsEnum.getBulkResult() to make its role clearer
--------------------------------------------------------

                 Key: LUCENE-2530
                 URL: https://issues.apache.org/jira/browse/LUCENE-2530
             Project: Lucene - Java
          Issue Type: Bug
          Components: Index
    Affects Versions: 4.0
            Reporter: Andi Vajda
            Assignee: Michael McCandless
            Priority: Minor


Before docsEnum.read() can be called a BulkResult instance must be allocated for it (it ==
the default implementation of that method).
This is done by calling docsEnum.getBulkResult(). Failure to call this method before read()
is called results in a NullPointerException.
It is somewhat counterintuitive to "get" the results of an operation before calling said operation.
Maybe this method should be renamed to something more definite-sounding like obtainBulkResult()
or prepareBulkResult() ?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message