lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Zhang <macromars...@gmail.com>
Subject Re: [BUG/ISSUE] Distributed Search doesn't response the result set when use existing lucene index
Date Tue, 08 Jun 2010 07:30:26 GMT
Hi. Koji.

Not sure how to set "uniqueKey" field in my lucene index. I am creating it
by using lucene.net

Document doc = new Document();
        doc.Add(new Field("id", product_obj.product_id.ToString(),
Field.Store.YES, Field.Index.UN_TOKENIZED));
        doc.Add(new Field("type", "product", Field.Store.YES,
Field.Index.UN_TOKENIZED));
        Field bField = new Field("keyword_level1", product_obj.title,
Field.Store.NO, Field.Index.ANALYZED);
        bField.SetBoost(10.0F);
        doc.Add(bField);
        //keyword_level1
        doc.Add(new Field("keyword_level1", product_obj.sku, Field.Store.NO,
Field.Index.NOT_ANALYZED));
        if (product_obj.is_zuup)
        {
            doc.Add(new Field("keyword_level1", "zuup", Field.Store.NO,
Field.Index.NOT_ANALYZED));
        }


Regards.
Scott


On Tue, Jun 8, 2010 at 3:25 PM, Koji Sekiguchi <koji@r.email.ne.jp> wrote:

> Are you sure you have uniqueKey field in your "lucene" index? Distributed
> search needs it.
>
> Koji Sekiguchi from mobile
>
>
>
> On 2010/06/08, at 15:52, Scott Zhang <macromarship@gmail.com> wrote:
>
>  Hi. All.
>>    I am coming from solr user mailing list. I got a problem with
>> distributed search. Looks it is BUG/ISSUE in solr itself.
>>
>>   I am trying to use solr to search over 2 lucene indexes.  I am following
>> the solr tutorial and test the distributed search example. It works.
>>   Then I am using my own lucene indexes. Search in each solr instance
>> works and return the expected result. But when I do distributed search using
>> "shards". It only return the "numFound"=14. But the result contain nothing.
>>
>>    The doc in my existing lucene indexes, when search with distributed
>> search, none of them are returned. But the docs inserted from solr post.jar
>> are returned successfully.
>>    Don't know why. looks the lucene docs has some difference from solr's
>> lucene.
>>    And my situation is, I already have 72 indexes folders which occupy
>> lots of disk and repost them to solr will take very long time, so I have to
>> stick with my existing index. Is there a solution for this?
>>
>>
>> Thanks.
>> Regards.
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>

Mime
View raw message