lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-2488) Fix 2.9 contrib builds to succeed when JDK 1.4 is used (leaving out contribs that require 1.5)
Date Sat, 05 Jun 2010 12:07:55 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2488?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12875900#action_12875900
] 

Uwe Schindler commented on LUCENE-2488:
---------------------------------------

bq.  I didnt want us to set a precedent where the build allows things to be skipped depending
on environment. Then the tests are passing for one developer and not for another, releasers
could accidentally not build all artifacts, ...

Thanks, I think the new option is fine now and works in all combinations. I already verified
that the whole build and test suite (with the ignore 1.5 contribs option) succeed with JDK
1.4.2_19. This is good to know as the release manager.

bq. Can we use this for Solr/Lucene on trunk/3x? Ie Solr requires JDK >= 1.6, but Lucene
is >= 1.5; we don't want 1.6 features to accidentally sneak into Lucene...

Of course, but we should do this in another issue. I will commit this evening and create the
release artifacts!

> Fix 2.9 contrib builds to succeed when JDK 1.4 is used (leaving out contribs that require
1.5)
> ----------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-2488
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2488
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 2.9, 2.9.1, 2.9.2
>            Reporter: Uwe Schindler
>            Assignee: Uwe Schindler
>             Fix For: 2.9.3
>
>         Attachments: LUCENE-2488.patch, LUCENE-2488.patch
>
>
> When you build and test Lucene 2.9 with Java 1.4, building and testing of contrib fails.
This patch fixes this to repect the current compiler version and disables all contribs that
need Java 1.5 by checking their javac.source property.
> This patch can be ported to 3.x or trunk, when 1.6 contribs will appear.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message