lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LUCENE-2488) Fix 2.9 contrib builds to succeed when JDK 1.4 is used (leaving out contribs that require 1.5)
Date Fri, 04 Jun 2010 23:36:03 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-2488?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Uwe Schindler updated LUCENE-2488:
----------------------------------

    Attachment: LUCENE-2488.patch

Patch for build.xmls. This also marks benchmark as 1.5, as it depends on fast-vector-highlighter
that is 1.5.

I will commit this soon and build the final artifacts of 2.9.3 and 3.0.2!

> Fix 2.9 contrib builds to succeed when JDK 1.4 is used (leaving out contribs that require
1.5)
> ----------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-2488
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2488
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 2.9, 2.9.1, 2.9.2
>            Reporter: Uwe Schindler
>            Assignee: Uwe Schindler
>             Fix For: 2.9.3
>
>         Attachments: LUCENE-2488.patch
>
>
> When you build and test Lucene 2.9 with Java 1.4, building and testing of contrib fails.
This patch fixes this to repect the current compiler version and disables all contribs that
need Java 1.5 by checking their javac.source property.
> This patch can be ported to 3.x or trunk, when 1.6 contribs will appear.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message