lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LUCENE-2487) IndexReader subclasses must implement flex APIs
Date Fri, 04 Jun 2010 21:02:56 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-2487?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael McCandless updated LUCENE-2487:
---------------------------------------

    Attachment: LUCENE-2487.patch

> IndexReader subclasses must implement flex APIs
> -----------------------------------------------
>
>                 Key: LUCENE-2487
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2487
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 4.0
>
>         Attachments: LUCENE-2487.patch
>
>
> To be fixed only on trunk...
> I made IndexReader's base flex APIs abstract, fixed all core/contrib/solr places that
subclassed IR and didn't already implement flex (including contrib/memory, contrib/instantiated),
and remove all the classes for the back-compat layer that emulated flex APIs on top of pre-flex
APIs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message