lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Earwin Burrfoot (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-2480) Remove support for pre-3.0 indexes
Date Sun, 30 May 2010 18:09:39 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2480?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12873465#action_12873465
] 

Earwin Burrfoot commented on LUCENE-2480:
-----------------------------------------

Wow! So fast! :)

bq. You didn't remove the .zip indexes?
Your patch didn't remove them for me, patch file format can't handle binary stuff.

bq. You removed the code from TestBackwardsCompatibilty ...... So I don't think we should
remove that piece of code.
Several lines later there sits a piece of absolutely identical commented-out code. The only
difference is that it doesn't use "preLockless" in method names.
If someone really needs it later, the code I left over suits him no less than the code I removed.

bq. TestIndexFileDeleter failed 'cause of deletable file - fixed it.
Cool! It's very strange I missed the failure.

bq. Renamed FORMAT_FLEX_POSTING to FORMAT_4_0
FORMAT_4_0_FLEX_POSTINGS? I loved the self-descriptiveness :)

And, yup. Bye-bye to the byte.

> Remove support for pre-3.0 indexes
> ----------------------------------
>
>                 Key: LUCENE-2480
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2480
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>            Reporter: Shai Erera
>            Assignee: Shai Erera
>            Priority: Minor
>             Fix For: 4.0
>
>         Attachments: LUCENE-2480.patch, LUCENE-2480.patch, LUCENE-2480.patch, LUCENE-2480.patch
>
>
> We should remove support for 2.x (and 1.9) indexes in 4.0. It seems that nothing can
be done in 3x because there is no special code which handles 1.9, so we'll leave it there.
This issue should cover:
> # Remove the .zip indexes
> # Remove the unnecessary code from SegmentInfo and SegmentInfos. Mike suggests we compare
the version headers at the top of SegmentInfos, in 2.9.x vs 3.0.x, to see which ones can go.
> # remove FORMAT_PRE from FieldInfos
> # Remove old format from TermVectorsReader
> If you know of other places where code can be removed, then please post a comment here.
> I don't know when I'll have time to handle it, definitely not in the next few days. So
if someone wants to take a stab at it, be my guest.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message