lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-2368) stopword files should be versioned; acessor for default(s) should take a Version property
Date Tue, 06 Apr 2010 01:50:27 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-2368?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12853691#action_12853691
] 

Hoss Man commented on LUCENE-2368:
----------------------------------

bq. I wonder if we should just break now (by renaming these 3) and version all the files so
its clean.

I didn't realize we even had those.

The other option is to *not* rename any of the files, but clearly document what the naming
convention is coming forward -- as i mentioned in the comment i just added (with more details
beyond the summary description) the names don't have to match Lucene Version semantics ...
they just have to be something that is unique moving forward.  Specificly: we should never
modify the contents of the files, we should just add a new file and "deprecate" the old file.

but the naming convention could easily be...

stopwords_esperanto.txt
stopwords_esperanto_2.txt
stopwords_esperanto_3.txt
...



> stopword files should be versioned; acessor for default(s) should take a Version property
> -----------------------------------------------------------------------------------------
>
>                 Key: LUCENE-2368
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2368
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Analysis
>            Reporter: Hoss Man
>             Fix For: 2.3.3
>
>
> The existing language specific stopword files on the trunk have no version info in their
filenames -- this will make it awkward/confusing to update them as time goes on.  LIkewise,
many classes have a "getDefaultStopSet()" which makes these methods (when called by client
code) suffer from the same API back-compat issues that the Analyzers themselves did before
we added Version.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message