lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (JIRA)" <>
Subject [jira] Commented: (LUCENE-2358) rename KeywordMarkerTokenFilter
Date Tue, 30 Mar 2010 23:46:27 GMT


Steven Rowe commented on LUCENE-2358:

Sorry for cluttering this issue...

I'm not really sure the KeywordAttribute is the best fit here, because its purpose is for
the token
to not be changed by some later filter. I'm not sure how your filter works (I would have to
see the patch),
but I think using this attribute for this purpose could introduce some bugs?

I guess the key is that its not a private-use attribute really, these things are visible by
all tokenstreams.
so stemmers etc will see your 'internal' attribute.

Yep, you're right, I hadn't thought it through that far.

bq. Would it make sense to have a generalized boolean attribute [...]?

I don't really think so. Since there can only be one of any attribute in the tokenstream,
you would have
various TokenFilters clashing on how they interpret and use some generic boolean attribute!

Um, yes, I should have realized that...

(Re-writing private FillerTokenAttribute! Hooray!)

> rename KeywordMarkerTokenFilter
> -------------------------------
>                 Key: LUCENE-2358
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: Analysis
>            Reporter: Robert Muir
>            Priority: Trivial
>         Attachments: LUCENE-2358.patch
> I would like to rename KeywordMarkerTokenFilter to KeywordMarkerFilter.
> We havent released it yet, so its a good time to keep the name brief and consistent.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message