lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <>
Subject [jira] Commented: (LUCENE-2285) Code cleanup from all sorts of (trivial) warnings
Date Sun, 28 Feb 2010 10:13:05 GMT


Shai Erera commented on LUCENE-2285:

Uwe, we are indeed deadlocked :).

I thought that it's not recommended to compile code w/ 1.5 and run it w/ 1.4, even if the
source level is 1.4. I remember a couple of issues with that, especially using Java 5.0 methods
such as Class.getSimpleName() (I remember because I introduced these problems :)). So I'm
not sure that I buy this argument ...

And I don't think that:
int int32 = (int) str.charAt(i+1);
introduces any sorts of safety, or makes the code clearer/more readable. It's just a redundant
cast, which has no effect because the compiler would cast to int even if you didn't put the
cast explicitly there. Same as doing *double res = (double) intval * 1.0* ...

I guess we need a tie breaker :).

> Code cleanup from all sorts of (trivial) warnings
> -------------------------------------------------
>                 Key: LUCENE-2285
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Shai Erera
>            Assignee: Uwe Schindler
>            Priority: Minor
>             Fix For: 3.1
>         Attachments: LUCENE-2285-remaining+generated.patch, LUCENE-2285-remaining.patch,
LUCENE-2285.patch, LUCENE-2285.patch, LUCENE-2285.patch
> I would like to do some code cleanup and remove all sorts of trivial warnings, like unnecessary
casts, problems w/ javadocs, unused variables, redundant null checks, unnecessary semicolon
etc. These are all very trivial and should not pose any problem.
> I'll create another issue for getting rid of deprecated code usage, like LuceneTestCase
and all sorts of deprecated constructors. That's also trivial because it only affects Lucene
code, but it's a different type of change.
> Another issue I'd like to create is about introducing more generics in the code, where
it's missing today - not changing existing API. There are many places in the code like that.
> So, with you permission, I'll start with the trivial ones first, and then move on to
the others.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message